summaryrefslogtreecommitdiffstats
path: root/test cases/java/8 codegen custom target/com/mesonbuild/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/java/8 codegen custom target/com/mesonbuild/meson.build')
-rw-r--r--test cases/java/8 codegen custom target/com/mesonbuild/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test cases/java/8 codegen custom target/com/mesonbuild/meson.build b/test cases/java/8 codegen custom target/com/mesonbuild/meson.build
new file mode 100644
index 0000000..0309941
--- /dev/null
+++ b/test cases/java/8 codegen custom target/com/mesonbuild/meson.build
@@ -0,0 +1,8 @@
+python = import('python').find_installation('python3')
+
+config_file = custom_target('confgen',
+ input : 'Config.java.in',
+ output : 'Config.java',
+ command : [python, '-c',
+ 'import shutil, sys, time; time.sleep(1); shutil.copy(sys.argv[1], sys.argv[2])',
+ '@INPUT@', '@OUTPUT@'])