summaryrefslogtreecommitdiffstats
path: root/test cases/python/2 extmodule/ext/nested
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/python/2 extmodule/ext/nested')
-rw-r--r--test cases/python/2 extmodule/ext/nested/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/test cases/python/2 extmodule/ext/nested/meson.build b/test cases/python/2 extmodule/ext/nested/meson.build
new file mode 100644
index 0000000..34c1192
--- /dev/null
+++ b/test cases/python/2 extmodule/ext/nested/meson.build
@@ -0,0 +1,15 @@
+py.extension_module('tachyon',
+ '../tachyon_module.c',
+ c_args: '-DMESON_MODULENAME="nested.tachyon"',
+ install: true,
+ subdir: 'nested'
+)
+py.install_sources(
+ configure_file(
+ input: '../../blaster.py.in',
+ output: 'blaster.py',
+ configuration: {'tachyon_module': 'nested.tachyon'}
+ ),
+ pure: false,
+ subdir: 'nested',
+)