summaryrefslogtreecommitdiffstats
path: root/test cases/python3/4 custom target depends extmodule/ext/lib
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/python3/4 custom target depends extmodule/ext/lib')
-rw-r--r--test cases/python3/4 custom target depends extmodule/ext/lib/meson-tachyonlib.c8
-rw-r--r--test cases/python3/4 custom target depends extmodule/ext/lib/meson-tachyonlib.h6
-rw-r--r--test cases/python3/4 custom target depends extmodule/ext/lib/meson.build4
3 files changed, 18 insertions, 0 deletions
diff --git a/test cases/python3/4 custom target depends extmodule/ext/lib/meson-tachyonlib.c b/test cases/python3/4 custom target depends extmodule/ext/lib/meson-tachyonlib.c
new file mode 100644
index 0000000..aeff296
--- /dev/null
+++ b/test cases/python3/4 custom target depends extmodule/ext/lib/meson-tachyonlib.c
@@ -0,0 +1,8 @@
+#ifdef _MSC_VER
+__declspec(dllexport)
+#endif
+const char*
+tachyon_phaser_command (void)
+{
+ return "shoot";
+}
diff --git a/test cases/python3/4 custom target depends extmodule/ext/lib/meson-tachyonlib.h b/test cases/python3/4 custom target depends extmodule/ext/lib/meson-tachyonlib.h
new file mode 100644
index 0000000..dca71d3
--- /dev/null
+++ b/test cases/python3/4 custom target depends extmodule/ext/lib/meson-tachyonlib.h
@@ -0,0 +1,6 @@
+#pragma once
+
+#ifdef _MSC_VER
+__declspec(dllimport)
+#endif
+const char* tachyon_phaser_command (void);
diff --git a/test cases/python3/4 custom target depends extmodule/ext/lib/meson.build b/test cases/python3/4 custom target depends extmodule/ext/lib/meson.build
new file mode 100644
index 0000000..b1f8938
--- /dev/null
+++ b/test cases/python3/4 custom target depends extmodule/ext/lib/meson.build
@@ -0,0 +1,4 @@
+libtachyon = shared_library('tachyonlib', 'meson-tachyonlib.c')
+
+libtachyon_dep = declare_dependency(link_with : libtachyon,
+ include_directories : include_directories('.'))