summaryrefslogtreecommitdiffstats
path: root/test cases/rust/4 polyglot/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/rust/4 polyglot/meson.build')
-rw-r--r--test cases/rust/4 polyglot/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/rust/4 polyglot/meson.build b/test cases/rust/4 polyglot/meson.build
new file mode 100644
index 0000000..3601d5e
--- /dev/null
+++ b/test cases/rust/4 polyglot/meson.build
@@ -0,0 +1,9 @@
+project('rust and c polyglot executable', 'c', 'rust')
+
+if host_machine.system() == 'darwin'
+ error('MESON_SKIP_TEST: does not work right on macos, please fix!')
+endif
+
+l = shared_library('stuff', 'stuff.rs', rust_crate_type: 'cdylib', install : true)
+e = executable('prog', 'prog.c', link_with : l, install : true)
+test('polyglottest', e)