summaryrefslogtreecommitdiffstats
path: root/test cases/unit/24 compiler run_command/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/unit/24 compiler run_command/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test cases/unit/24 compiler run_command/meson.build b/test cases/unit/24 compiler run_command/meson.build
new file mode 100644
index 0000000..e99b880
--- /dev/null
+++ b/test cases/unit/24 compiler run_command/meson.build
@@ -0,0 +1,10 @@
+project('compiler_object_in_run_command', 'c')
+cc = meson.get_compiler('c')
+
+# This test only checks that the compiler object can be passed to
+# run_command(). If the compiler has been launched, it is expected
+# to output something either to stdout or to stderr.
+result = run_command(cc, '--version', check: false)
+if result.stdout() == '' and result.stderr() == ''
+ error('No output in stdout and stderr. Did the compiler run at all?')
+endif