summaryrefslogtreecommitdiffstats
path: root/test cases/unit/34 command line/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/unit/34 command line/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/unit/34 command line/meson.build b/test cases/unit/34 command line/meson.build
new file mode 100644
index 0000000..6207ca5
--- /dev/null
+++ b/test cases/unit/34 command line/meson.build
@@ -0,0 +1,9 @@
+project('command line test', 'c',
+ default_options : ['default_library=static', 'set_sub_opt=true']
+)
+
+if get_option('set_sub_opt')
+ subproject('subp', default_options : ['subp_opt=default3'])
+else
+ subproject('subp')
+endif