summaryrefslogtreecommitdiffstats
path: root/test cases/unit/94 custominc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/94 custominc/meson.build')
-rw-r--r--test cases/unit/94 custominc/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/unit/94 custominc/meson.build b/test cases/unit/94 custominc/meson.build
new file mode 100644
index 0000000..bab1139
--- /dev/null
+++ b/test cases/unit/94 custominc/meson.build
@@ -0,0 +1,9 @@
+project('implicit custom dirs', 'c')
+
+subdir('easytogrepfor')
+
+l = static_library('helper', 'helper.c', genh)
+d = declare_dependency(link_with: l, sources: genh)
+executable('prog', 'prog.c', dependencies: d, implicit_include_directories: false)
+
+executable('prog2', 'prog2.c', dependencies: d)