summaryrefslogtreecommitdiffstats
path: root/test cases/vala/12 custom output/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/vala/12 custom output/meson.build')
-rw-r--r--test cases/vala/12 custom output/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/test cases/vala/12 custom output/meson.build b/test cases/vala/12 custom output/meson.build
new file mode 100644
index 0000000..c328959
--- /dev/null
+++ b/test cases/vala/12 custom output/meson.build
@@ -0,0 +1,13 @@
+project('valatest', 'c', 'vala')
+
+glib = dependency('glib-2.0')
+gobject = dependency('gobject-2.0')
+
+foo_lib = library('foo-1.0', 'foo.vala',
+ vala_header: 'foo.h',
+ vala_vapi: 'foo.vapi',
+ dependencies: [glib, gobject])
+
+library('bar', 'bar.vala',
+ link_with: [foo_lib],
+ dependencies: [glib, gobject])