summaryrefslogtreecommitdiffstats
path: root/test cases/windows/12 resources with custom targets/res/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/windows/12 resources with custom targets/res/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/test cases/windows/12 resources with custom targets/res/meson.build b/test cases/windows/12 resources with custom targets/res/meson.build
new file mode 100644
index 0000000..9797637
--- /dev/null
+++ b/test cases/windows/12 resources with custom targets/res/meson.build
@@ -0,0 +1,19 @@
+win = import('windows')
+
+rc_writer = find_program('./gen-res.py')
+
+rc_sources = []
+
+foreach id : [1, 2]
+ rc_sources += custom_target('RC source file @0@'.format(id),
+ input : 'myres.rc.in',
+ output : 'myres_@0@.rc'.format(id),
+ command : [rc_writer, '@INPUT@', '@OUTPUT@', files('sample.ico')],
+ install : false,
+ build_always : false)
+endforeach
+
+rc_sources += files('myres_static.rc')
+
+res = win.compile_resources(rc_sources,
+ include_directories: include_directories('.'))