summaryrefslogtreecommitdiffstats
path: root/test cases/windows/14 resources with custom target depend_files/ico/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/windows/14 resources with custom target depend_files/ico/meson.build')
-rw-r--r--test cases/windows/14 resources with custom target depend_files/ico/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test cases/windows/14 resources with custom target depend_files/ico/meson.build b/test cases/windows/14 resources with custom target depend_files/ico/meson.build
new file mode 100644
index 0000000..3fae9e8
--- /dev/null
+++ b/test cases/windows/14 resources with custom target depend_files/ico/meson.build
@@ -0,0 +1,8 @@
+ico_writer = find_program('gen-ico.py')
+
+ico = custom_target('makeico',
+ input : 'sample.ico.in',
+ output : 'sample.ico',
+ command : [ico_writer, '@INPUT@', '@OUTPUT@'],
+ install : false,
+ build_always : false)