summaryrefslogtreecommitdiffstats
path: root/test cases/windows/15 resource scripts with duplicate filenames/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/windows/15 resource scripts with duplicate filenames/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/test cases/windows/15 resource scripts with duplicate filenames/meson.build b/test cases/windows/15 resource scripts with duplicate filenames/meson.build
new file mode 100644
index 0000000..9fa3525
--- /dev/null
+++ b/test cases/windows/15 resource scripts with duplicate filenames/meson.build
@@ -0,0 +1,21 @@
+project('foobar', 'c')
+
+win = import('windows')
+
+subdir('a')
+subdir('b')
+subdir('c')
+subdir('exe3')
+subdir('exe4')
+
+main = win.compile_resources('rsrc.rc')
+
+testa = executable('testa', 'verify.c', a)
+testb = executable('testb', 'verify.c', b)
+testc = executable('testc', 'verify.c', c)
+testmain = executable('testmain', 'verify.c', main)
+
+test('a', testa, args: 'a')
+test('b', testb, args: 'b')
+test('c', testc, args: 'c')
+test('main', testmain, args: 'main')