summaryrefslogtreecommitdiffstats
path: root/test cases/windows/18 msvc charset/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/windows/18 msvc charset/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/test cases/windows/18 msvc charset/meson.build b/test cases/windows/18 msvc charset/meson.build
new file mode 100644
index 0000000..bb6f667
--- /dev/null
+++ b/test cases/windows/18 msvc charset/meson.build
@@ -0,0 +1,15 @@
+project('charset', 'c')
+
+cc = meson.get_compiler('c')
+
+if cc.get_id() != 'msvc'
+ error('MESON_SKIP_TEST requires MSVC.')
+endif
+
+executable('utf8', 'utf8.c')
+
+if get_option('test-failure')
+ executable('iso-8859-1', 'iso-8859-1.c')
+else
+ executable('iso-8859-1', 'iso-8859-1.c', c_args: '/source-charset:.850')
+endif