summaryrefslogtreecommitdiffstats
path: root/test cases/windows/20 vs install static lib with generated obj deps/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/windows/20 vs install static lib with generated obj deps/meson.build')
-rw-r--r--test cases/windows/20 vs install static lib with generated obj deps/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test cases/windows/20 vs install static lib with generated obj deps/meson.build b/test cases/windows/20 vs install static lib with generated obj deps/meson.build
new file mode 100644
index 0000000..bc61772
--- /dev/null
+++ b/test cases/windows/20 vs install static lib with generated obj deps/meson.build
@@ -0,0 +1,20 @@
+project('test', 'c')
+
+generated_c = custom_target(
+ 'generated.c',
+ input : files('generated_source.c', 'copyfile.py'),
+ output : 'generated.c',
+ command : ['python', '@INPUT1@', '@INPUT0@', '@OUTPUT@'],
+)
+
+static_lib = static_library(
+ 'static_lib',
+ [files('static_lib_source.c'), generated_c],
+)
+
+both_lib = both_libraries(
+ 'both_lib',
+ [files('both_lib_source.c')],
+ link_with : [static_lib],
+ install : true,
+)