summaryrefslogtreecommitdiffstats
path: root/test cases/windows/8 find program
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/windows/8 find program/meson.build12
-rw-r--r--test cases/windows/8 find program/test-script3
-rw-r--r--test cases/windows/8 find program/test-script-ext.py3
3 files changed, 18 insertions, 0 deletions
diff --git a/test cases/windows/8 find program/meson.build b/test cases/windows/8 find program/meson.build
new file mode 100644
index 0000000..565fb62
--- /dev/null
+++ b/test cases/windows/8 find program/meson.build
@@ -0,0 +1,12 @@
+project('find program', 'c')
+
+# Test that we can find native windows executables
+find_program('cmd')
+find_program('cmd.exe')
+
+# Test that a script file with an extension can be found
+ext = find_program('test-script-ext.py')
+test('ext', ext)
+# Test that a script file without an extension can be found
+prog = find_program('test-script')
+test('script', prog)
diff --git a/test cases/windows/8 find program/test-script b/test cases/windows/8 find program/test-script
new file mode 100644
index 0000000..e764165
--- /dev/null
+++ b/test cases/windows/8 find program/test-script
@@ -0,0 +1,3 @@
+#!/usr/bin/env python3
+
+print('1')
diff --git a/test cases/windows/8 find program/test-script-ext.py b/test cases/windows/8 find program/test-script-ext.py
new file mode 100644
index 0000000..ae9adfb
--- /dev/null
+++ b/test cases/windows/8 find program/test-script-ext.py
@@ -0,0 +1,3 @@
+#!/usr/bin/env python3
+
+print('ext/noext')