summaryrefslogtreecommitdiffstats
path: root/libnetdata/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libnetdata/Makefile.am')
-rw-r--r--libnetdata/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/libnetdata/Makefile.am b/libnetdata/Makefile.am
new file mode 100644
index 0000000..1208d16
--- /dev/null
+++ b/libnetdata/Makefile.am
@@ -0,0 +1,37 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+SUBDIRS = \
+ adaptive_resortable_list \
+ arrayalloc \
+ avl \
+ buffer \
+ clocks \
+ completion \
+ config \
+ dictionary \
+ ebpf \
+ eval \
+ json \
+ health \
+ locks \
+ log \
+ onewayalloc \
+ popen \
+ procfile \
+ simple_pattern \
+ socket \
+ statistical \
+ storage_number \
+ string \
+ threads \
+ url \
+ worker_utilization \
+ tests \
+ $(NULL)
+
+dist_noinst_DATA = \
+ README.md \
+ $(NULL)