summaryrefslogtreecommitdiffstats
path: root/CMakeOptions.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:32:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:32:08 +0000
commit328ad0a41c6bdf596224ff2e9ab9c0fabde8634d (patch)
tree973585a56cea8664b4be63b5bb737b443e4e2b76 /CMakeOptions.txt
parentInitial commit. (diff)
downloadnghttp3-upstream.tar.xz
nghttp3-upstream.zip
Adding upstream version 0.8.0.upstream/0.8.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--CMakeOptions.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeOptions.txt b/CMakeOptions.txt
new file mode 100644
index 0000000..7f0a2e1
--- /dev/null
+++ b/CMakeOptions.txt
@@ -0,0 +1,11 @@
+# Features that can be enabled for cmake (see CMakeLists.txt)
+
+option(ENABLE_WERROR "Make compiler warnings fatal" OFF)
+option(ENABLE_DEBUG "Turn on debug output")
+option(ENABLE_ASAN "Enable AddressSanitizer (ASAN)" OFF)
+option(ENABLE_LIB_ONLY "Build libnghttp3 only" OFF)
+option(ENABLE_STATIC_LIB "Build libnghttp3 as a static library" ON)
+option(ENABLE_SHARED_LIB "Build libnghttp3 as a shared library" ON)
+option(ENABLE_STATIC_CRT "Build libnghttp3 against the MS LIBCMT[d]")
+
+# vim: ft=cmake: