summaryrefslogtreecommitdiffstats
path: root/CMakeOptions.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeOptions.txt')
-rw-r--r--CMakeOptions.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeOptions.txt b/CMakeOptions.txt
new file mode 100644
index 0000000..7f0a2e1
--- /dev/null
+++ b/CMakeOptions.txt
@@ -0,0 +1,11 @@
+# Features that can be enabled for cmake (see CMakeLists.txt)
+
+option(ENABLE_WERROR "Make compiler warnings fatal" OFF)
+option(ENABLE_DEBUG "Turn on debug output")
+option(ENABLE_ASAN "Enable AddressSanitizer (ASAN)" OFF)
+option(ENABLE_LIB_ONLY "Build libnghttp3 only" OFF)
+option(ENABLE_STATIC_LIB "Build libnghttp3 as a static library" ON)
+option(ENABLE_SHARED_LIB "Build libnghttp3 as a shared library" ON)
+option(ENABLE_STATIC_CRT "Build libnghttp3 against the MS LIBCMT[d]")
+
+# vim: ft=cmake: