summaryrefslogtreecommitdiffstats
path: root/CMakeOptions.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:30:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:30:55 +0000
commit17e81f2cd1843f01838245eae7b5ed5edf83d6be (patch)
treea0f685dff11ce5a2dc546a7b46a48bae5d1c0140 /CMakeOptions.txt
parentInitial commit. (diff)
downloadngtcp2-17e81f2cd1843f01838245eae7b5ed5edf83d6be.tar.xz
ngtcp2-17e81f2cd1843f01838245eae7b5ed5edf83d6be.zip
Adding upstream version 0.12.1+dfsg.upstream/0.12.1+dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'CMakeOptions.txt')
-rw-r--r--CMakeOptions.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeOptions.txt b/CMakeOptions.txt
new file mode 100644
index 0000000..090b3fc
--- /dev/null
+++ b/CMakeOptions.txt
@@ -0,0 +1,17 @@
+# Features that can be enabled for cmake (see CMakeLists.txt)
+
+option(ENABLE_STATIC_LIB "Build as static libraries" ON)
+option(ENABLE_SHARED_LIB "Build as shared libraries" ON)
+
+option(ENABLE_WERROR "Make compiler warnings fatal" OFF)
+option(ENABLE_DEBUG "Turn on debug output" OFF)
+option(ENABLE_ASAN "Enable AddressSanitizer (ASAN)" OFF)
+option(ENABLE_JEMALLOC "Enable Jemalloc" OFF)
+
+option(ENABLE_GNUTLS "Enable GnuTLS crypto backend" OFF)
+option(ENABLE_OPENSSL "Enable OpenSSL crypto backend (required for examples)" ON)
+option(ENABLE_BORINGSSL "Enable BoringSSL crypto backend" OFF)
+option(ENABLE_PICOTLS "Enable Picotls crypto backend" OFF)
+option(ENABLE_WOLFSSL "Enable wolfSSL crypto backend" OFF)
+
+# vim: ft=cmake: