summaryrefslogtreecommitdiffstats
path: root/CMakeOptions.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeOptions.txt')
-rw-r--r--CMakeOptions.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeOptions.txt b/CMakeOptions.txt
new file mode 100644
index 0000000..090b3fc
--- /dev/null
+++ b/CMakeOptions.txt
@@ -0,0 +1,17 @@
+# Features that can be enabled for cmake (see CMakeLists.txt)
+
+option(ENABLE_STATIC_LIB "Build as static libraries" ON)
+option(ENABLE_SHARED_LIB "Build as shared libraries" ON)
+
+option(ENABLE_WERROR "Make compiler warnings fatal" OFF)
+option(ENABLE_DEBUG "Turn on debug output" OFF)
+option(ENABLE_ASAN "Enable AddressSanitizer (ASAN)" OFF)
+option(ENABLE_JEMALLOC "Enable Jemalloc" OFF)
+
+option(ENABLE_GNUTLS "Enable GnuTLS crypto backend" OFF)
+option(ENABLE_OPENSSL "Enable OpenSSL crypto backend (required for examples)" ON)
+option(ENABLE_BORINGSSL "Enable BoringSSL crypto backend" OFF)
+option(ENABLE_PICOTLS "Enable Picotls crypto backend" OFF)
+option(ENABLE_WOLFSSL "Enable wolfSSL crypto backend" OFF)
+
+# vim: ft=cmake: