summaryrefslogtreecommitdiffstats
path: root/ccan/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ccan/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/ccan/meson.build b/ccan/meson.build
new file mode 100644
index 0000000..4ba3b5f
--- /dev/null
+++ b/ccan/meson.build
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+sources += files([
+ 'ccan/list/list.c',
+ 'ccan/str/debug.c',
+ 'ccan/str/str.c',
+])
+
+if get_option('buildtype') == 'debug'
+ add_project_arguments('-DCCAN_LIST_DEBUG=1', language : ['c'])
+ add_project_arguments('-DCCAN_STR_DEBUG=1', language : ['c'])
+endif