summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:00:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:00:33 +0000
commit96fcf3ea3a51071dfeca141b7c9b0e5e3e5365a8 (patch)
tree51d766882e3eacda67f6a3b0df8ae3df7d157e20 /Makefile.am
parentInitial commit. (diff)
downloadnwipe-96fcf3ea3a51071dfeca141b7c9b0e5e3e5365a8.tar.xz
nwipe-96fcf3ea3a51071dfeca141b7c9b0e5e3e5365a8.zip
Adding upstream version 0.34.upstream/0.34upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..0df77f5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,9 @@
+SUBDIRS = src man
+
+# The set of files to be formatted.
+FORMATSOURCES = src/*.c src/*.h
+format:
+ clang-format -i -style=file $(FORMATSOURCES)
+
+check-format:
+ clang-format -i -style=file $(FORMATSOURCES) && git diff --exit-code