summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:43:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:43:18 +0000
commitcc5717cdf86886c3dbaea40dfc8dc9e501b1cf1f (patch)
tree2dae3914f7c48ebc5d0e27e9d3bdbaea8210a30f /src/Makefile.am
parentInitial commit. (diff)
downloadopentracing-c-wrapper-cc5717cdf86886c3dbaea40dfc8dc9e501b1cf1f.tar.xz
opentracing-c-wrapper-cc5717cdf86886c3dbaea40dfc8dc9e501b1cf1f.zip
Adding upstream version 1.1.3.upstream/1.1.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bd72329
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,52 @@
+## Process this file with automake to produce Makefile.in
+##
+##
+AM_CPPFLAGS = @OPENTRACING_C_WRAPPER_CPPFLAGS@
+ AM_CFLAGS = @OPENTRACING_C_WRAPPER_CFLAGS@
+AM_CXXFLAGS = @OPENTRACING_C_WRAPPER_CXXFLAGS@
+ AM_LDFLAGS = @OPENTRACING_C_WRAPPER_LDFLAGS@
+ LIBS = @LIBS@ @OPENTRACING_C_WRAPPER_LIBS@
+
+if WANT_DEBUG
+lib_LTLIBRARIES = libopentracing-c-wrapper_dbg.la
+pkgconfig_DATA = ../opentracing-c-wrapper_dbg.pc
+
+libopentracing_c_wrapper_dbg_la_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/../include
+libopentracing_c_wrapper_dbg_la_CFLAGS = $(AM_CFLAGS)
+libopentracing_c_wrapper_dbg_la_CXXFLAGS = $(AM_CXXFLAGS)
+libopentracing_c_wrapper_dbg_la_LDFLAGS = $(AM_LDFLAGS) -version-info @LIB_VERSION@ -Wl,--version-script=$(srcdir)/export_dbg.map
+libopentracing_c_wrapper_dbg_la_SOURCES = \
+ dbg_malloc.cpp \
+ span.cpp \
+ tracer.cpp \
+ util.cpp
+
+else
+
+lib_LTLIBRARIES = libopentracing-c-wrapper.la
+pkgconfig_DATA = ../opentracing-c-wrapper.pc
+
+libopentracing_c_wrapper_la_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/../include
+libopentracing_c_wrapper_la_CFLAGS = $(AM_CFLAGS)
+libopentracing_c_wrapper_la_CXXFLAGS = $(AM_CXXFLAGS)
+libopentracing_c_wrapper_la_LDFLAGS = $(AM_LDFLAGS) -version-info @LIB_VERSION@ -Wl,--version-script=$(srcdir)/export.map
+libopentracing_c_wrapper_la_SOURCES = \
+ span.cpp \
+ tracer.cpp \
+ util.cpp
+endif
+
+pkginclude_HEADERS = \
+ ../include/opentracing-c-wrapper/common.h \
+ ../include/opentracing-c-wrapper/dbg_malloc.h \
+ ../include/opentracing-c-wrapper/define.h \
+ ../include/opentracing-c-wrapper/include.h \
+ ../include/opentracing-c-wrapper/propagation.h \
+ ../include/opentracing-c-wrapper/span.h \
+ ../include/opentracing-c-wrapper/tracer.h \
+ ../include/opentracing-c-wrapper/util.h \
+ ../include/opentracing-c-wrapper/value.h
+
+CLEANFILES = a.out
+##
+## Makefile.am ends here