summaryrefslogtreecommitdiffstats
path: root/debian/patches/riscv64-link-libatomic.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:44:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:44:33 +0000
commitbf7aef61e7a785e8c8ec47b4dc044e9861e7d1be (patch)
treeff330426bce05c3909a1bc67bf48f531ee79b36a /debian/patches/riscv64-link-libatomic.patch
parentAdding upstream version 1.6.0. (diff)
downloadopentracing-cpp-bf7aef61e7a785e8c8ec47b4dc044e9861e7d1be.tar.xz
opentracing-cpp-bf7aef61e7a785e8c8ec47b4dc044e9861e7d1be.zip
Adding debian version 1.6.0-4.debian/1.6.0-4debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--debian/patches/riscv64-link-libatomic.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/patches/riscv64-link-libatomic.patch b/debian/patches/riscv64-link-libatomic.patch
new file mode 100644
index 0000000..42bf93f
--- /dev/null
+++ b/debian/patches/riscv64-link-libatomic.patch
@@ -0,0 +1,15 @@
+Description: Link libatomic on riscv64 and fix FTBFS
+Author: Eric Long <i@hack3r.moe>
+Last-Update: 2022-09-03
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -155,6 +155,9 @@
+ list(APPEND LIBRARIES ${CMAKE_DL_LIBS})
+ endif()
+
++if (${CMAKE_SYSTEM_PROCESSOR} STREQUAL "riscv64")
++ list(APPEND LIBRARIES atomic)
++endif()
+
+ if (BUILD_SHARED_LIBS)
+ add_library(opentracing SHARED ${SRCS})