summaryrefslogtreecommitdiffstats
path: root/example/tutorial/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:44:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:44:33 +0000
commitb196c6498d22e47bb9d0da0153068ec54eac7956 (patch)
tree1a994a492581e93224a7ee6455f5d4e9d2ec8e59 /example/tutorial/CMakeLists.txt
parentInitial commit. (diff)
downloadopentracing-cpp-b196c6498d22e47bb9d0da0153068ec54eac7956.tar.xz
opentracing-cpp-b196c6498d22e47bb9d0da0153068ec54eac7956.zip
Adding upstream version 1.6.0.upstream/1.6.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--example/tutorial/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/example/tutorial/CMakeLists.txt b/example/tutorial/CMakeLists.txt
new file mode 100644
index 0000000..11daf16
--- /dev/null
+++ b/example/tutorial/CMakeLists.txt
@@ -0,0 +1,6 @@
+if (BUILD_MOCKTRACER AND BUILD_SHARED_LIBS)
+ include_directories(../../mocktracer/include)
+ add_executable(tutorial-example tutorial-example.cpp)
+ target_link_libraries(tutorial-example opentracing_mocktracer)
+ add_test(NAME tutorial-example COMMAND tutorial-example)
+endif()