summaryrefslogtreecommitdiffstats
path: root/src/test/modules/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
commit6eb9c5a5657d1fe77b55cc261450f3538d35a94d (patch)
tree657d8194422a5daccecfd42d654b8a245ef7b4c8 /src/test/modules/Makefile
parentInitial commit. (diff)
downloadpostgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.tar.xz
postgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.zip
Adding upstream version 13.4.upstream/13.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/modules/Makefile')
-rw-r--r--src/test/modules/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/test/modules/Makefile b/src/test/modules/Makefile
new file mode 100644
index 0000000..29de73c
--- /dev/null
+++ b/src/test/modules/Makefile
@@ -0,0 +1,35 @@
+# src/test/modules/Makefile
+
+subdir = src/test/modules
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+SUBDIRS = \
+ brin \
+ commit_ts \
+ dummy_index_am \
+ dummy_seclabel \
+ snapshot_too_old \
+ test_bloomfilter \
+ test_ddl_deparse \
+ test_extensions \
+ test_ginpostinglist \
+ test_integerset \
+ test_misc \
+ test_parser \
+ test_pg_dump \
+ test_predtest \
+ test_rbtree \
+ test_rls_hooks \
+ test_shm_mq \
+ unsafe_tests \
+ worker_spi
+
+ifeq ($(with_openssl),yes)
+SUBDIRS += ssl_passphrase_callback
+else
+ALWAYS_SUBDIRS += ssl_passphrase_callback
+endif
+
+$(recurse)
+$(recurse_always)