summaryrefslogtreecommitdiffstats
path: root/contrib/dict_xsyn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/dict_xsyn/Makefile')
-rw-r--r--contrib/dict_xsyn/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/contrib/dict_xsyn/Makefile b/contrib/dict_xsyn/Makefile
new file mode 100644
index 0000000..b6bcfe6
--- /dev/null
+++ b/contrib/dict_xsyn/Makefile
@@ -0,0 +1,24 @@
+# contrib/dict_xsyn/Makefile
+
+MODULE_big = dict_xsyn
+OBJS = \
+ $(WIN32RES) \
+ dict_xsyn.o
+
+EXTENSION = dict_xsyn
+DATA = dict_xsyn--1.0.sql
+DATA_TSEARCH = xsyn_sample.rules
+PGFILEDESC = "dict_xsyn - add-on dictionary template for full-text search"
+
+REGRESS = dict_xsyn
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/dict_xsyn
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif