summaryrefslogtreecommitdiffstats
path: root/contrib/tsm_system_rows/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/tsm_system_rows/Makefile')
-rw-r--r--contrib/tsm_system_rows/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/contrib/tsm_system_rows/Makefile b/contrib/tsm_system_rows/Makefile
new file mode 100644
index 0000000..3192ed5
--- /dev/null
+++ b/contrib/tsm_system_rows/Makefile
@@ -0,0 +1,23 @@
+# contrib/tsm_system_rows/Makefile
+
+MODULE_big = tsm_system_rows
+OBJS = \
+ $(WIN32RES) \
+ tsm_system_rows.o
+PGFILEDESC = "tsm_system_rows - TABLESAMPLE method which accepts number of rows as a limit"
+
+EXTENSION = tsm_system_rows
+DATA = tsm_system_rows--1.0.sql
+
+REGRESS = tsm_system_rows
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/tsm_system_rows
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif