summaryrefslogtreecommitdiffstats
path: root/contrib/fuzzystrmatch/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
commit46651ce6fe013220ed397add242004d764fc0153 (patch)
tree6e5299f990f88e60174a1d3ae6e48eedd2688b2b /contrib/fuzzystrmatch/Makefile
parentInitial commit. (diff)
downloadpostgresql-14-46651ce6fe013220ed397add242004d764fc0153.tar.xz
postgresql-14-46651ce6fe013220ed397add242004d764fc0153.zip
Adding upstream version 14.5.upstream/14.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--contrib/fuzzystrmatch/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/contrib/fuzzystrmatch/Makefile b/contrib/fuzzystrmatch/Makefile
new file mode 100644
index 0000000..0704894
--- /dev/null
+++ b/contrib/fuzzystrmatch/Makefile
@@ -0,0 +1,24 @@
+# contrib/fuzzystrmatch/Makefile
+
+MODULE_big = fuzzystrmatch
+OBJS = \
+ $(WIN32RES) \
+ dmetaphone.o \
+ fuzzystrmatch.o
+
+EXTENSION = fuzzystrmatch
+DATA = fuzzystrmatch--1.1.sql fuzzystrmatch--1.0--1.1.sql
+PGFILEDESC = "fuzzystrmatch - similarities and distance between strings"
+
+REGRESS = fuzzystrmatch
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/fuzzystrmatch
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif