summaryrefslogtreecommitdiffstats
path: root/contrib/hstore/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
commit46651ce6fe013220ed397add242004d764fc0153 (patch)
tree6e5299f990f88e60174a1d3ae6e48eedd2688b2b /contrib/hstore/Makefile
parentInitial commit. (diff)
downloadpostgresql-14-46651ce6fe013220ed397add242004d764fc0153.tar.xz
postgresql-14-46651ce6fe013220ed397add242004d764fc0153.zip
Adding upstream version 14.5.upstream/14.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/hstore/Makefile')
-rw-r--r--contrib/hstore/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/contrib/hstore/Makefile b/contrib/hstore/Makefile
new file mode 100644
index 0000000..c4e339b
--- /dev/null
+++ b/contrib/hstore/Makefile
@@ -0,0 +1,36 @@
+# contrib/hstore/Makefile
+
+MODULE_big = hstore
+OBJS = \
+ $(WIN32RES) \
+ hstore_compat.o \
+ hstore_gin.o \
+ hstore_gist.o \
+ hstore_io.o \
+ hstore_op.o \
+ hstore_subs.o
+
+EXTENSION = hstore
+DATA = hstore--1.4.sql \
+ hstore--1.7--1.8.sql \
+ hstore--1.6--1.7.sql \
+ hstore--1.5--1.6.sql \
+ hstore--1.4--1.5.sql \
+ hstore--1.3--1.4.sql hstore--1.2--1.3.sql \
+ hstore--1.1--1.2.sql
+PGFILEDESC = "hstore - key/value pair data type"
+
+HEADERS = hstore.h
+
+REGRESS = hstore
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/hstore
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif