summaryrefslogtreecommitdiffstats
path: root/contrib/oid2name/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
commit46651ce6fe013220ed397add242004d764fc0153 (patch)
tree6e5299f990f88e60174a1d3ae6e48eedd2688b2b /contrib/oid2name/Makefile
parentInitial commit. (diff)
downloadpostgresql-14-46651ce6fe013220ed397add242004d764fc0153.tar.xz
postgresql-14-46651ce6fe013220ed397add242004d764fc0153.zip
Adding upstream version 14.5.upstream/14.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--contrib/oid2name/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/contrib/oid2name/Makefile b/contrib/oid2name/Makefile
new file mode 100644
index 0000000..6179ed5
--- /dev/null
+++ b/contrib/oid2name/Makefile
@@ -0,0 +1,25 @@
+# contrib/oid2name/Makefile
+
+PGFILEDESC = "oid2name - examine the file structure"
+PGAPPICON = win32
+
+PROGRAM = oid2name
+OBJS = \
+ $(WIN32RES) \
+ oid2name.o
+
+TAP_TESTS = 1
+
+PG_CPPFLAGS = -I$(libpq_srcdir)
+PG_LIBS_INTERNAL = $(libpq_pgport)
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/oid2name
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif