summaryrefslogtreecommitdiffstats
path: root/contrib/pg_trgm/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
commit46651ce6fe013220ed397add242004d764fc0153 (patch)
tree6e5299f990f88e60174a1d3ae6e48eedd2688b2b /contrib/pg_trgm/Makefile
parentInitial commit. (diff)
downloadpostgresql-14-46651ce6fe013220ed397add242004d764fc0153.tar.xz
postgresql-14-46651ce6fe013220ed397add242004d764fc0153.zip
Adding upstream version 14.5.upstream/14.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/pg_trgm/Makefile')
-rw-r--r--contrib/pg_trgm/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/contrib/pg_trgm/Makefile b/contrib/pg_trgm/Makefile
new file mode 100644
index 0000000..1fbdc9e
--- /dev/null
+++ b/contrib/pg_trgm/Makefile
@@ -0,0 +1,28 @@
+# contrib/pg_trgm/Makefile
+
+MODULE_big = pg_trgm
+OBJS = \
+ $(WIN32RES) \
+ trgm_gin.o \
+ trgm_gist.o \
+ trgm_op.o \
+ trgm_regexp.o
+
+EXTENSION = pg_trgm
+DATA = pg_trgm--1.5--1.6.sql pg_trgm--1.4--1.5.sql pg_trgm--1.3--1.4.sql \
+ pg_trgm--1.3.sql pg_trgm--1.2--1.3.sql pg_trgm--1.1--1.2.sql \
+ pg_trgm--1.0--1.1.sql
+PGFILEDESC = "pg_trgm - trigram matching"
+
+REGRESS = pg_trgm pg_word_trgm pg_strict_word_trgm
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/pg_trgm
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif