summaryrefslogtreecommitdiffstats
path: root/src/test/isolation/specs/multiple-cic.spec
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
commit46651ce6fe013220ed397add242004d764fc0153 (patch)
tree6e5299f990f88e60174a1d3ae6e48eedd2688b2b /src/test/isolation/specs/multiple-cic.spec
parentInitial commit. (diff)
downloadpostgresql-14-upstream.tar.xz
postgresql-14-upstream.zip
Adding upstream version 14.5.upstream/14.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/test/isolation/specs/multiple-cic.spec43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/test/isolation/specs/multiple-cic.spec b/src/test/isolation/specs/multiple-cic.spec
new file mode 100644
index 0000000..e34a6b0
--- /dev/null
+++ b/src/test/isolation/specs/multiple-cic.spec
@@ -0,0 +1,43 @@
+# Test multiple CREATE INDEX CONCURRENTLY working simultaneously
+
+setup
+{
+ CREATE TABLE mcic_one (
+ id int
+ );
+ CREATE TABLE mcic_two (
+ id int
+ );
+ CREATE FUNCTION lck_shr(bigint) RETURNS bool IMMUTABLE LANGUAGE plpgsql AS $$
+ BEGIN PERFORM pg_advisory_lock_shared($1); RETURN true; END;
+ $$;
+ CREATE FUNCTION unlck() RETURNS bool IMMUTABLE LANGUAGE plpgsql AS $$
+ BEGIN PERFORM pg_advisory_unlock_all(); RETURN true; END;
+ $$;
+}
+teardown
+{
+ DROP TABLE mcic_one, mcic_two;
+ DROP FUNCTION lck_shr(bigint);
+ DROP FUNCTION unlck();
+}
+
+session s1
+step s1i {
+ CREATE INDEX CONCURRENTLY mcic_one_pkey ON mcic_one (id)
+ WHERE lck_shr(281457);
+ }
+teardown { SELECT unlck(); }
+
+
+session s2
+step s2l { SELECT pg_advisory_lock(281457); }
+step s2i {
+ CREATE INDEX CONCURRENTLY mcic_two_pkey ON mcic_two (id)
+ WHERE unlck();
+ }
+
+# (*) marker ensures that s2i is reported as "waiting", even if it
+# completes very quickly
+
+permutation s2l s1i s2i(*)