summaryrefslogtreecommitdiffstats
path: root/src/backend/bootstrap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/backend/bootstrap/Makefile')
-rw-r--r--src/backend/bootstrap/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/backend/bootstrap/Makefile b/src/backend/bootstrap/Makefile
new file mode 100644
index 0000000..6421efb
--- /dev/null
+++ b/src/backend/bootstrap/Makefile
@@ -0,0 +1,25 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for the bootstrap module
+#
+# src/backend/bootstrap/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/backend/bootstrap
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+override CPPFLAGS := -I. -I$(srcdir) $(CPPFLAGS)
+
+OBJS = \
+ bootparse.o \
+ bootstrap.o
+
+include $(top_srcdir)/src/backend/common.mk
+
+# bootscanner is compiled as part of bootparse
+bootparse.o: bootscanner.c
+
+# bootparse.c and bootscanner.c are in the distribution tarball, so
+# they are not cleaned here.