summaryrefslogtreecommitdiffstats
path: root/src/test/README
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/README')
-rw-r--r--src/test/README50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/test/README b/src/test/README
new file mode 100644
index 0000000..afdc767
--- /dev/null
+++ b/src/test/README
@@ -0,0 +1,50 @@
+PostgreSQL tests
+================
+
+This directory contains a variety of test infrastructure as well as some of the
+tests in PostgreSQL. Not all tests are here -- in particular, there are more in
+individual contrib/ modules and in src/bin.
+
+Not all these tests get run by "make check". Check src/test/Makefile to see
+which tests get run automatically.
+
+authentication/
+ Tests for authentication (but see also below)
+
+examples/
+ Demonstration programs for libpq that double as regression tests via
+ "make check"
+
+isolation/
+ Tests for concurrent behavior at the SQL level
+
+kerberos/
+ Tests for Kerberos/GSSAPI authentication and encryption
+
+ldap/
+ Tests for LDAP-based authentication
+
+locale/
+ Sanity checks for locale data, encodings, etc
+
+mb/
+ Tests for multibyte encoding (UTF-8) support
+
+modules/
+ Extensions used only or mainly for test purposes, generally not suitable
+ for installing in production databases
+
+perl/
+ Infrastructure for Perl-based TAP tests
+
+recovery/
+ Test suite for recovery and replication
+
+regress/
+ PostgreSQL's main regression test suite, pg_regress
+
+ssl/
+ Tests to exercise and verify SSL certificate handling
+
+subscription/
+ Tests for logical replication