summaryrefslogtreecommitdiffstats
path: root/contrib/dblink/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /contrib/dblink/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/dblink/Makefile')
-rw-r--r--contrib/dblink/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/contrib/dblink/Makefile b/contrib/dblink/Makefile
new file mode 100644
index 0000000..d4c7ed6
--- /dev/null
+++ b/contrib/dblink/Makefile
@@ -0,0 +1,27 @@
+# contrib/dblink/Makefile
+
+MODULE_big = dblink
+OBJS = \
+ $(WIN32RES) \
+ dblink.o
+PG_CPPFLAGS = -I$(libpq_srcdir)
+SHLIB_LINK_INTERNAL = $(libpq)
+
+EXTENSION = dblink
+DATA = dblink--1.2.sql dblink--1.1--1.2.sql dblink--1.0--1.1.sql
+PGFILEDESC = "dblink - connect to other PostgreSQL databases"
+
+REGRESS = dblink
+REGRESS_OPTS = --dlpath=$(top_builddir)/src/test/regress
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+SHLIB_PREREQS = submake-libpq
+subdir = contrib/dblink
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif