summaryrefslogtreecommitdiffstats
path: root/contrib/hstore/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /contrib/hstore/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/hstore/Makefile')
-rw-r--r--contrib/hstore/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/contrib/hstore/Makefile b/contrib/hstore/Makefile
new file mode 100644
index 0000000..48ee98f
--- /dev/null
+++ b/contrib/hstore/Makefile
@@ -0,0 +1,36 @@
+# contrib/hstore/Makefile
+
+MODULE_big = hstore
+OBJS = \
+ $(WIN32RES) \
+ hstore_compat.o \
+ hstore_gin.o \
+ hstore_gist.o \
+ hstore_io.o \
+ hstore_op.o \
+ hstore_subs.o
+
+EXTENSION = hstore
+DATA = hstore--1.4.sql \
+ hstore--1.7--1.8.sql \
+ hstore--1.6--1.7.sql \
+ hstore--1.5--1.6.sql \
+ hstore--1.4--1.5.sql \
+ hstore--1.3--1.4.sql hstore--1.2--1.3.sql \
+ hstore--1.1--1.2.sql
+PGFILEDESC = "hstore - key/value pair data type"
+
+HEADERS = hstore.h
+
+REGRESS = hstore hstore_utf8
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/hstore
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif