summaryrefslogtreecommitdiffstats
path: root/contrib/intarray/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /contrib/intarray/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/intarray/Makefile')
-rw-r--r--contrib/intarray/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/contrib/intarray/Makefile b/contrib/intarray/Makefile
new file mode 100644
index 0000000..3817c16
--- /dev/null
+++ b/contrib/intarray/Makefile
@@ -0,0 +1,31 @@
+# contrib/intarray/Makefile
+
+MODULE_big = _int
+OBJS = \
+ $(WIN32RES) \
+ _int_bool.o \
+ _int_gin.o \
+ _int_gist.o \
+ _int_op.o \
+ _int_selfuncs.o \
+ _int_tool.o \
+ _intbig_gist.o
+
+EXTENSION = intarray
+DATA = intarray--1.4--1.5.sql intarray--1.3--1.4.sql intarray--1.2--1.3.sql \
+ intarray--1.2.sql intarray--1.1--1.2.sql \
+ intarray--1.0--1.1.sql
+PGFILEDESC = "intarray - functions and operators for arrays of integers"
+
+REGRESS = _int
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/intarray
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif