summaryrefslogtreecommitdiffstats
path: root/src/backend/access/heap/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/backend/access/heap/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/backend/access/heap/Makefile')
-rw-r--r--src/backend/access/heap/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/backend/access/heap/Makefile b/src/backend/access/heap/Makefile
new file mode 100644
index 0000000..af0bd18
--- /dev/null
+++ b/src/backend/access/heap/Makefile
@@ -0,0 +1,26 @@
+#-------------------------------------------------------------------------
+#
+# Makefile--
+# Makefile for access/heap
+#
+# IDENTIFICATION
+# src/backend/access/heap/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/backend/access/heap
+top_builddir = ../../../..
+include $(top_builddir)/src/Makefile.global
+
+OBJS = \
+ heapam.o \
+ heapam_handler.o \
+ heapam_visibility.o \
+ heaptoast.o \
+ hio.o \
+ pruneheap.o \
+ rewriteheap.o \
+ vacuumlazy.o \
+ visibilitymap.o
+
+include $(top_srcdir)/src/backend/common.mk