summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.darwin
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/makefiles/Makefile.darwin
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/makefiles/Makefile.darwin14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.darwin b/src/makefiles/Makefile.darwin
new file mode 100644
index 0000000..4fc81c1
--- /dev/null
+++ b/src/makefiles/Makefile.darwin
@@ -0,0 +1,14 @@
+AROPT = crs
+
+# env var name to use in place of LD_LIBRARY_PATH
+ld_library_path_var = DYLD_LIBRARY_PATH
+
+ifdef PGXS
+ BE_DLLLIBS = -bundle_loader $(bindir)/postgres
+else
+ BE_DLLLIBS = -bundle_loader $(top_builddir)/src/backend/postgres
+endif
+
+# Rule for building a shared library from a single .o file
+%.so: %.o
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -bundle $(BE_DLLLIBS) -o $@