summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.hpux
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/makefiles/Makefile.hpux
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/makefiles/Makefile.hpux')
-rw-r--r--src/makefiles/Makefile.hpux47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.hpux b/src/makefiles/Makefile.hpux
new file mode 100644
index 0000000..25e036b
--- /dev/null
+++ b/src/makefiles/Makefile.hpux
@@ -0,0 +1,47 @@
+# Using X/Open Networking Interfaces requires to link with libxnet.
+# Without specifying this, bind(), getpeername() and so on don't work
+# correctly in the LP64 data model.
+LIBS := -lxnet $(LIBS)
+
+# Set up rpath so that the executables don't need SHLIB_PATH to be set.
+# (Note: --disable-rpath is a really bad idea on this platform...)
+ifeq ($(with_gnu_ld), yes)
+ rpath = -Wl,-rpath -Wl,'$(rpathdir)'
+else
+ rpath = -Wl,+b -Wl,'$(rpathdir)'
+endif
+
+# catch null pointer dereferences
+ifeq ($(with_gnu_ld), yes)
+# XXX what to put here?
+else
+ LDFLAGS_EX += -Wl,-z
+endif
+
+# set up appropriate options for shared library builds
+export_dynamic = -Wl,-E
+
+INSTALL_SHLIB_OPTS = -m 555
+
+AROPT = crs
+
+# env var name to use in place of LD_LIBRARY_PATH
+ld_library_path_var = SHLIB_PATH
+
+# Rule for building a shared library from a single .o file
+%$(DLSUFFIX): %.o
+ifeq ($(GCC), yes)
+ ifeq ($(with_gnu_ld), yes)
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -shared -o $@ `$(CC) $(LDFLAGS) -print-libgcc-file-name`
+ else
+ $(LD) -b -o $@ $< `$(CC) $(LDFLAGS) -print-libgcc-file-name`
+ endif
+else
+ ifeq ($(with_gnu_ld), yes)
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -shared -o $@
+ else
+ $(LD) -b -o $@ $<
+ endif
+endif
+
+sqlmansect = 5