summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.solaris
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/makefiles/Makefile.solaris
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/makefiles/Makefile.solaris')
-rw-r--r--src/makefiles/Makefile.solaris21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.solaris b/src/makefiles/Makefile.solaris
new file mode 100644
index 0000000..5496edc
--- /dev/null
+++ b/src/makefiles/Makefile.solaris
@@ -0,0 +1,21 @@
+# src/makefiles/Makefile.solaris
+
+AROPT = crs
+
+ifeq ($(with_gnu_ld), yes)
+export_dynamic = -Wl,-E
+rpath = -Wl,-rpath,'$(rpathdir)'
+else
+rpath = -Wl,-R'$(rpathdir)'
+endif
+
+
+# Rule for building a shared library from a single .o file
+%.so: %.o
+ifeq ($(GCC), yes)
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -shared -o $@
+else
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -G -o $@
+endif
+
+sqlmansect = 5sql