summaryrefslogtreecommitdiffstats
path: root/src/pl/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/pl/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/pl/Makefile')
-rw-r--r--src/pl/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/pl/Makefile b/src/pl/Makefile
new file mode 100644
index 0000000..c4a0d1c
--- /dev/null
+++ b/src/pl/Makefile
@@ -0,0 +1,36 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for src/pl (procedural languages)
+#
+# Copyright (c) 1994, Regents of the University of California
+#
+# src/pl/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/pl
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+
+SUBDIRS = plpgsql
+
+ifeq ($(with_perl), yes)
+SUBDIRS += plperl
+else
+ALWAYS_SUBDIRS += plperl
+endif
+
+ifeq ($(with_python), yes)
+SUBDIRS += plpython
+else
+ALWAYS_SUBDIRS += plpython
+endif
+
+ifeq ($(with_tcl), yes)
+SUBDIRS += tcl
+else
+ALWAYS_SUBDIRS += tcl
+endif
+
+$(recurse)
+$(recurse_always)