summaryrefslogtreecommitdiffstats
path: root/src/test/locale/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/test/locale/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/locale/Makefile')
-rw-r--r--src/test/locale/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/test/locale/Makefile b/src/test/locale/Makefile
new file mode 100644
index 0000000..7ba096b
--- /dev/null
+++ b/src/test/locale/Makefile
@@ -0,0 +1,22 @@
+# src/test/locale/Makefile
+
+subdir = src/test/locale
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+
+PROGS = test-ctype
+DIRS = de_DE.ISO8859-1 gr_GR.ISO8859-7 koi8-r koi8-to-win1251
+
+all: $(PROGS)
+
+clean distclean maintainer-clean:
+ rm -f $(PROGS) *.o
+ rm -rf tmp_check
+ for d in $(DIRS); do \
+ $(MAKE) -C $$d clean || exit; \
+ done
+
+# These behave like installcheck targets.
+check-%: all
+ @$(MAKE) -C `echo $@ | sed 's/^check-//'` test