summaryrefslogtreecommitdiffstats
path: root/src/timezone/tznames/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/timezone/tznames/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/timezone/tznames/Makefile')
-rw-r--r--src/timezone/tznames/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/timezone/tznames/Makefile b/src/timezone/tznames/Makefile
new file mode 100644
index 0000000..e80bf53
--- /dev/null
+++ b/src/timezone/tznames/Makefile
@@ -0,0 +1,30 @@
+#-------------------------------------------------------------------------
+#
+# Makefile
+# Makefile for the timezone names
+
+# IDENTIFICATION
+# src/timezone/tznames/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/timezone/tznames
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+TZNAMES_TEMPLATES = Africa.txt America.txt Antarctica.txt Asia.txt \
+ Atlantic.txt Australia.txt Etc.txt Europe.txt Indian.txt Pacific.txt
+TZNAMES_TEMPLATES_FILES = $(TZNAMES_TEMPLATES:%=$(srcdir)/%)
+
+TZNAMES_SETS = Default Australia India
+TZNAMES_SETS_FILES = $(TZNAMES_SETS:%=$(srcdir)/%)
+
+install: installdirs
+ $(INSTALL_DATA) $(TZNAMES_TEMPLATES_FILES) '$(DESTDIR)$(datadir)/timezonesets'
+ $(INSTALL_DATA) $(TZNAMES_SETS_FILES) '$(DESTDIR)$(datadir)/timezonesets'
+
+installdirs:
+ $(MKDIR_P) '$(DESTDIR)$(datadir)/timezonesets'
+
+uninstall:
+ rm -rf '$(DESTDIR)$(datadir)/timezonesets'