summaryrefslogtreecommitdiffstats
path: root/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile77
1 files changed, 77 insertions, 0 deletions
diff --git a/src/Makefile b/src/Makefile
new file mode 100644
index 0000000..79e274a
--- /dev/null
+++ b/src/Makefile
@@ -0,0 +1,77 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for src
+#
+# Copyright (c) 1994, Regents of the University of California
+#
+# src/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src
+top_builddir = ..
+include Makefile.global
+
+SUBDIRS = \
+ common \
+ port \
+ timezone \
+ backend \
+ backend/utils/mb/conversion_procs \
+ backend/snowball \
+ include \
+ interfaces \
+ backend/replication/libpqwalreceiver \
+ backend/replication/pgoutput \
+ fe_utils \
+ bin \
+ pl \
+ makefiles \
+ test/regress \
+ test/isolation \
+ test/perl
+
+ifeq ($(with_llvm), yes)
+SUBDIRS += backend/jit/llvm
+endif
+
+# There are too many interdependencies between the subdirectories, so
+# don't attempt parallel make here.
+.NOTPARALLEL:
+
+$(recurse)
+
+install: install-local
+
+install-local: installdirs-local
+ $(INSTALL_DATA) Makefile.global '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global'
+ $(INSTALL_DATA) Makefile.port '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.port'
+ $(INSTALL_DATA) $(srcdir)/Makefile.shlib '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.shlib'
+ $(INSTALL_DATA) $(srcdir)/nls-global.mk '$(DESTDIR)$(pgxsdir)/$(subdir)/nls-global.mk'
+
+installdirs: installdirs-local
+
+installdirs-local:
+ $(MKDIR_P) '$(DESTDIR)$(pgxsdir)/$(subdir)'
+
+uninstall: uninstall-local
+
+uninstall-local:
+ rm -f $(addprefix '$(DESTDIR)$(pgxsdir)/$(subdir)'/, Makefile.global Makefile.port Makefile.shlib nls-global.mk)
+
+distprep:
+ $(MAKE) -C test/isolation $@
+
+clean:
+ $(MAKE) -C test $@
+ $(MAKE) -C tutorial NO_PGXS=1 $@
+ $(MAKE) -C test/isolation $@
+
+distclean maintainer-clean:
+ $(MAKE) -C test $@
+ $(MAKE) -C tutorial NO_PGXS=1 $@
+ $(MAKE) -C test/isolation $@
+ rm -f Makefile.port Makefile.global
+
+
+.PHONY: install-local installdirs-local uninstall-local