summaryrefslogtreecommitdiffstats
path: root/src/interfaces/libpq/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/interfaces/libpq/test/Makefile')
-rw-r--r--src/interfaces/libpq/test/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/interfaces/libpq/test/Makefile b/src/interfaces/libpq/test/Makefile
new file mode 100644
index 0000000..75ac08f
--- /dev/null
+++ b/src/interfaces/libpq/test/Makefile
@@ -0,0 +1,24 @@
+# src/interfaces/libpq/test/Makefile
+
+PGFILEDESC = "libpq test program"
+PGAPPICON = win32
+
+subdir = src/interfaces/libpq/test
+top_builddir = ../../../..
+include $(top_builddir)/src/Makefile.global
+
+ifeq ($(PORTNAME), win32)
+LDFLAGS += -lws2_32
+endif
+
+override CPPFLAGS := -I$(libpq_srcdir) $(CPPFLAGS)
+LDFLAGS_INTERNAL += $(libpq_pgport)
+
+PROGS = libpq_testclient libpq_uri_regress
+
+all: $(PROGS)
+
+$(PROGS): $(WIN32RES)
+
+clean distclean maintainer-clean:
+ rm -f $(PROGS) *.o