summaryrefslogtreecommitdiffstats
path: root/src/pl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/pl/Makefile')
-rw-r--r--src/pl/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/pl/Makefile b/src/pl/Makefile
new file mode 100644
index 0000000..c4a0d1c
--- /dev/null
+++ b/src/pl/Makefile
@@ -0,0 +1,36 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for src/pl (procedural languages)
+#
+# Copyright (c) 1994, Regents of the University of California
+#
+# src/pl/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/pl
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+
+SUBDIRS = plpgsql
+
+ifeq ($(with_perl), yes)
+SUBDIRS += plperl
+else
+ALWAYS_SUBDIRS += plperl
+endif
+
+ifeq ($(with_python), yes)
+SUBDIRS += plpython
+else
+ALWAYS_SUBDIRS += plpython
+endif
+
+ifeq ($(with_tcl), yes)
+SUBDIRS += tcl
+else
+ALWAYS_SUBDIRS += tcl
+endif
+
+$(recurse)
+$(recurse_always)