summaryrefslogtreecommitdiffstats
path: root/src/test/regress/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/regress/Makefile')
-rw-r--r--src/test/regress/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/test/regress/Makefile b/src/test/regress/Makefile
new file mode 100644
index 0000000..7c665ff
--- /dev/null
+++ b/src/test/regress/Makefile
@@ -0,0 +1,17 @@
+# The Postgres make files exploit features of GNU make that other makes
+# do not have. Because it is a common mistake for users to try to build
+# Postgres with a different make, we have this make file that does nothing
+# but tell the user to use GNU make.
+
+# If the user were using GNU make now, this file would not get used because
+# GNU make uses a make file named "GNUmakefile" in preference to "Makefile"
+# if it exists. Postgres is shipped with a "GNUmakefile".
+
+
+# AIX make defaults to building *every* target of the first rule. Start with
+# a single-target, empty rule to make the other targets non-default.
+all:
+
+all install clean check installcheck:
+ @echo "You must use GNU make to use Postgres. It may be installed"
+ @echo "on your system with the name 'gmake'."