summaryrefslogtreecommitdiffstats
path: root/.travis.yml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:35:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:35:20 +0000
commite106bf94eff07d9a59771d9ccc4406421e18ab64 (patch)
treeedb6545500e39df9c67aa918a6125bffc8ec1aee /.travis.yml
parentInitial commit. (diff)
downloadprompt-toolkit-e106bf94eff07d9a59771d9ccc4406421e18ab64.tar.xz
prompt-toolkit-e106bf94eff07d9a59771d9ccc4406421e18ab64.zip
Adding upstream version 3.0.36.upstream/3.0.36upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--.travis.yml35
1 files changed, 35 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..0091119
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,35 @@
+os: linux
+dist: focal
+cache: pip
+language: python
+
+jobs:
+ include:
+ - python: 3.8
+ - python: 3.7
+ - python: 3.6
+
+install:
+ - pip install . black coverage codecov flake8 isort mypy pytest readme_renderer
+ - pip list
+
+script:
+ - echo "$TRAVIS_PYTHON_VERSION"
+ - flake8 prompt_toolkit
+ - coverage run -m pytest
+
+ # Run type checker.
+ - mypy prompt_toolkit
+
+ # Check wheather the imports were sorted correctly.
+ # When this fails, please run ./tools/sort-imports.sh
+ - isort -c -rc --profile black prompt_toolkit examples tests setup.py
+
+ - black --check prompt_toolkit examples tests setup.py
+
+ # Ensure that the README renders correctly (required for uploading to PyPI).
+ - python -m readme_renderer README.rst > /dev/null
+
+
+after_success:
+ - codecov