summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:20:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:20:41 +0000
commitb49f1524e250764592ff132af8fb0d39182620f7 (patch)
treea2c4da0c1bfc3be79c9b80180d8958804e91a07d /.pre-commit-config.yaml
parentInitial commit. (diff)
downloadpython-build-b49f1524e250764592ff132af8fb0d39182620f7.tar.xz
python-build-b49f1524e250764592ff132af8fb0d39182620f7.zip
Adding upstream version 0.9.0.upstream/0.9.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml68
1 files changed, 68 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 0000000..7c72733
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,68 @@
+ci:
+ autofix_prs: false
+ autoupdate_commit_msg: "pre-commit: bump repositories"
+
+repos:
+ - repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v4.3.0
+ hooks:
+ - id: check-ast
+ - id: check-builtin-literals
+ - id: check-docstring-first
+ - id: check-merge-conflict
+ - id: check-yaml
+ - id: check-toml
+ exclude: tests/packages/test-(bad-syntax|no-permission)/pyproject.toml
+ - id: debug-statements
+ - id: end-of-file-fixer
+ - id: trailing-whitespace
+ - id: double-quote-string-fixer
+ - repo: https://github.com/asottile/pyupgrade
+ rev: v3.1.0
+ hooks:
+ - id: pyupgrade
+ args: ["--py36-plus"]
+ - repo: https://github.com/psf/black
+ rev: 22.10.0
+ hooks:
+ - id: black
+ - repo: https://github.com/asottile/blacken-docs
+ rev: v1.12.1
+ hooks:
+ - id: blacken-docs
+ additional_dependencies: [black==22.6]
+ - repo: https://github.com/pre-commit/mirrors-prettier
+ rev: "v3.0.0-alpha.2"
+ hooks:
+ - id: prettier
+ - repo: https://github.com/PyCQA/isort
+ rev: 5.10.1
+ hooks:
+ - id: isort
+ - repo: https://github.com/asottile/setup-cfg-fmt
+ rev: v2.1.0
+ hooks:
+ - id: setup-cfg-fmt
+ args: [--include-version-classifiers, --max-py-version=3.11]
+ - repo: https://github.com/PyCQA/flake8
+ rev: "5.0.4"
+ hooks:
+ - id: flake8
+ additional_dependencies: ["flake8-bugbear==22.7.1"]
+ language_version: python3.9
+ - repo: https://github.com/codespell-project/codespell
+ rev: "v2.2.2"
+ hooks:
+ - id: codespell
+ args: ["-L", "sur"]
+ - repo: https://github.com/pre-commit/pygrep-hooks
+ rev: "v1.9.0"
+ hooks:
+ - id: python-check-blanket-noqa
+ - id: python-check-blanket-type-ignore
+ - id: python-no-log-warn
+ - id: python-no-eval
+ - id: python-use-type-annotations
+ - id: rst-backticks
+ - id: rst-directive-colons
+ - id: rst-inline-touching-normal